SAP Knowledge Base Article - Public

3672748 - EC Alerts not triggering in the instance - SAP SuccessFactors Employee Central

Symptom

  • Alerts are not triggering in the instance.
  • Same configurations are working as expected in other instances.
  • EC Alerts and Notifications job is successful and shows alerts created for each rule, but tiles are not created and notifications are not received.
  • "Last Successful Run Date" is not updated in the job.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Make a change to a subject user of the alerts rule.
  2. Run the EC Alerts and Notifications job.
  3. Observe that no alerts are triggered, and the alert rules are not captured in the trace.

Cause

Configuration issue. There is an alert rule configured in BCUI which is no longer valid, for example in globalAssignmentInfo.

Resolution

Navigate to "Manage Business Configuration" and check all sections that have saveAlert rules. Confirm if all the rules are valid and remove the invalid ones, then normally run the job.

See Also

Refer to: Creating custom alert messages

Keywords

alerts not triggering, preview instance, contract expiry notifications, EC Alerts and Notifications job, saveAlert rule, invalid rule configuration, CreateECAlert error, SAP SuccessFactors Employee Central, alert message configuration, business rule correction, BCUI, globalassignmentinfo , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions