SAP Knowledge Base Article - Public

3672786 - Missing proxy information in workflow activity section

Symptom

  • After initiating a workflow for an employee, a user proxies as every step of the approver and approves the workflow.
  • In the workflow detail page, activity section, some steps are missing the "proxy as" information.
  • The missing information results in an incomplete activity log for certain steps in the workflow.

Environment

SuccessFactors Employee Central

Reproducing the Issue

  1. Navigate to the user's profile and check the record for the workflow history.
  2. Then check activity section in the workflow details page.
  3. For both UIs, for certain steps the "on behalf of" proxy information is missing.

Cause

The missing "proxy as" information occurs when a proxy approver does mass approval. This behavior is expected, as mass approval does not record proxy information for individual steps.

Resolution

  1. If proxy approval is required, avoid using the mass approval functionality.
  2. Instead, approve workflows individually to ensure that the "proxy as" information is correctly recorded in the activity section.

See Also

Keywords

workflow activity section, proxy information missing, sap successfactors employee central, workflows, activity log, mass approval, todo card, proxy approver, missing information, workflow history, sap successfactors platform, INC15874793  , KBA , LOD-SF-EC-WFL-REQ , My Pending Requests, ToDo's & Mass Approvals , How To

Product

SAP SuccessFactors Employee Central all versions