Symptom
- When a product is assigned to multiple categories and one category’s permission is set to “disabled,” the product catalog search incorrectly displays the product under that category if it is the top ranked association, instead of displaying it under the next available, enabled category.
- This issue results in the product being visible under a category where access should be restricted, negatively affecting permission enforcement and user experience.
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Add a product with multiple categories.
- Map category ranks to 1 and 2.
- Set the permission for rank 1 category to not display to anyone (deactivate).
- Search for the product in the catalog; it will still show rank 1 category even though it is disabled.
Cause
Bug in the application.
Resolution
- The tentative fix version is set to 2602.
- Updates will be provided if the fix version changes.
- Please monitor this KBA for further updates regarding the resolution.
See Also
3487591 - Known Issues in SAP CPQ
Keywords
product catalog search, disabled category, category visibility, permission enforcement, sap cpq, multiple categories, product association, category rank, bug , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public