SAP Knowledge Base Article - Public

3673417 - Postal Code Search Discrepancy Between Account and Individual Customer Objects.

Symptom

  • Account and Individual Customer objects do not provide the same result for Global Searches.
  • Postal Code search works for Individual Customer objects but does not work for Account objects in Global Search.
  • Searching for Postal Code does not yield expected results for Account objects.
  • Opportunities and Leads are displayed in Global search when searching for Postal Codes, but Account details are not shown.

Environment

  • SAP Cloud for Customer

Reproducing the Issue

  1. Go to Home Page.
  2. Click on Global search.
  3. Search using the postal code "XXXX" under "All Categories" (where XXX is the Postal Code number).
  4. Observe that only Opportunities and Leads are displayed for Postal Codes, while Account details are not shown.

Cause

  • Postal Code search functionality is not enabled for Account objects in Global Search.

Resolution

  1. Go to Global search.
  2. Select "Accounts" instead of "All Categories".
  3. Click on "Advanced" and enter the Postal Code.
  4. Click on "Search" at the bottom of the page.
  5. Click on the "Simple" button at the top to view the Account search results.

See Also

  • Refer to: 3118424 Not Possible Include KUT Fields in the Enterprise Search / Global Search Section.
  • Refer to: 3612283 Premise and Contract Account are not available in Global Search.

Keywords

Postal Code Search, Account Search, Individual Customer, Enterprise Search, Global Search, Advanced Search, Opportunities, Lead , KBA , LOD-CRM-ACC , Account , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , AP-RC-UIF , C4C UI Framework , Known Error

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions