Symptom
The "Correct My Personal Data" button in Form I-9 Section 1 is grayed out and cannot be clicked.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Access the instance
- Proxy as an onboarding user.
- Open Form I-9 Section 1
- Attempt to click the "Correct My Personal Data" button.
Cause
The engineering team has found that the issue happens with SSO-based instances where the API check fails, and the button is greyed out.
Resolution
The fix date will be deployed in patch 3 timelines (4-Nov-25) for the preview environment.
Please, check the see also section to get more detailed information for the patch dates.
Click on star to bookmark this article in order to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KBA 2171560 - How to be notified of new or updated SAP Notes or KBAs - SAP ONE Support Launchpad.
See Also
SAP SuccessFactors Product Release & Road Map Information
SAP SuccessFactors Patches Knowledge Base
KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs
Keywords
correct my personal data, grayed out button, form i-9 section 1, obx, KI2H2025, OBX-40851, personal data , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Known Error
SAP Knowledge Base Article - Public