SAP Knowledge Base Article - Public

3673769 - Custom Logic - External Pre Hook Support To Update Array Data Type Attributes of Case Entity

Symptom

You want to understand which array-type attributes of the Case entity can be updated using Custom Logic External Pre Hook, and what the exceptions and limitations are for certain attributes like Notes and Attachments.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Cause

By design, certain array-type attributes within the Case entity can be updated through the External Pre Hook functionality in Custom Logic. However, for specific attributes (such as Notes and Attachments), update and deletion behaviors differ due to system-level constraints.

Resolution

At the time of preparation of this document, the following array-type attributes of the Case entity are updatable via External Pre Hook:

  • registeredProducts
  • functionalLocations
  • productInstallPoints
  • installedBases
  • products
  • approvers
  • customAccounts
  • customIndividualCustomers
  • customContacts
  • customEmployees
  • customSuppliers
  • customSupplierContacts
  • customOrganizations
  • notes
  • attachments
  • relatedObjects
  • contractAccounts
  • premises

All the above attributes can be updated via the External Pre Hook, including the creation or deletion of array objects, except for the notes and attachments attributes.

Exceptions and Special Handling
1. Notes

A new note can be created and appended to the existing list of notes.

However, the newly created note must not be linked to the case during creation. It should be created as an orphan note (unlinked) and appended to the existing list. This ensures proper linking of the note to the case instance.

Removing a linked note from the list does not delete the note.

Deletion of notes must be performed via the Note-Service endpoint.

Removing orphan/unlinked notes from the list ensures that they are not linked to the case instance.

2. Attachments

Similar to notes, a new attachment can be created and appended to the existing list of attachments.

Removing linked attachments from the list does not delete them.

Deletion of attachments must be performed via the Case-Service endpoint.

Removing unlinked attachments from the list ensures that they are not linked to the case instance.

Keywords

Custom Logic, External Pre Hook, Case Entity, Array Attributes, Notes, Attachments, Case Management , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0