Symptom
You would like to use specific fields in the Advanced Search of the Service Order work list, but notice that the fields are not available to be added via the Adaptation Mode.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to the SAP Service Cloud Version 2 tenant.
- Navigate to the Service Order work list.
- Click on the User Profile.
- Click Start Adaptation.
- Expand the Advanced Filter.
- Click on the Pencil next to the Advanced Search
- Select Add From List.
- See the field required is not available to be used.
Cause
This might be the case if the field required is not set with the flag "Filterable" as "True" in the Service Order entity in the Extensibility Administration.
Resolution
To validate this, follow the steps below:
- Click on the User Profile.
- Click Settings.
- Navigate to All Settings.
- Click Extensibility Administration under Extensibility.
- Search for Service Order Service.
- Click on Service Order.
- Navigate to Field Query Properties tab.
- Find the field.
- See the column Filterable.
In case the option is grayed out, then it has been set as such by the standard design of the system.
Keywords
Service Order, Service, Order, V2, Version 2, SAP Service Cloud Version 2, Field Query Properties, Filterable, Advanced Search, Search, Advanced, Filter, Not Available, Field, Adaptation Mode, Adaptation, , KBA , CEC-CRM-SRVO , Service Order for SAP Sales/Service Cloud , How To
SAP Knowledge Base Article - Public