SAP Knowledge Base Article - Public

3673940 - Notes are not visible in the output form

Symptom

When an entity (e.g. visit) has multiple notes, this information is not displayed in the form (only the first note is displayed in the form).

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.  

Environment

SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Open navigation menu.
  2. Go to visits view.
  3. Open any visit that has multiple notes.
  4. Click on the 3 dots button and select View summary.
  5. In the pdf preview only the first note is shown.
  6. Expectation: All notes should be visible in the pdf preview.

Cause

The surrounding sub-form 'visitNotesSubform' was not marked as repeatable. Because of that, only the first note element was being rendered.

Resolution

To solve this, please make the 'visitNotesSubform' repeatable for each notes[*] element in Adobe LiveCycle Designer.

Keywords

Visit, Notes, Note, Form, Output, PDF , KBA , CEC-CRM-OUT , Output Management for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0