Symptom
- Credit management block is not triggered at the Post Goods Issue (PGI) process step.
- The system allows users to perform PGI even when credit limits are exceeded for business partners, despite proper credit master data maintenance.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
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Create a sales order.
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Save and create the delivery.
- Perform PGI documents and observe that system is allowing PGI without any credit block.
Cause
- The issue occurs because credit check controls at the PGI (Post Goods Issue) level are not properly configured.
- In SAP S/4HANA Cloud Public Edition, credit checks can be set up separately for sales order, delivery, and PGI levels.
Resolution
To enable credit checks at the PGI level, perform the following configuration steps:
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Navigate to SSCUI 101518 - Define Automatic Credit Control.
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Set the credit segment and risk class according to your business scenario, and set Credit Group(CG) to 03 (which represents PGI level).
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Enable SAP Credit Management Check:
- Select on the SAP Credit Management button.
- Set Reaction parameter.
- Select on the Status/Block button.
Note:
- The updated configuration will only take effect for PGI documents created after this change.
- PGI documents created before modifying these settings are not affected, as per standard SAP behavior.
Keywords
Credit block, PGI, Post Goods Issue, credit check not working, SSCUI 101518, credit limit, SAP S/4HANA Cloud Public Edition, define automatic credit control, risk class, credit group, SAP Credit Management, finance, configuration, credit control, sales order, delivery. , KBA , FIN-FSCM-CR-2CL , Credit Management (Public Cloud) , Problem
SAP Knowledge Base Article - Public