Symptom
- When creating a recurring visit in Outlook, only the first recurrence appears in the C4C calendar, and subsequent sequences do not reflect.
- Error message: "CC-024: Individual event to series conversion not supported".
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Cloud for Customer,
Outlook integration
Reproducing the Issue
- Navigate to Outlook and create an appointment.
- Click on the + icon in the SSI side bar to link the object
- Save the event.
- Observe that the event does not reflect in the C4C calendar.
Cause
The issue occurs because the user creates a normal (non-recurring) event first by clicking the "+" button and then attempts to convert it into a recurring event. This action is not supported.
Resolution
- Navigate to Outlook and create a recurring appointment directly.
- Open the Server-Side Integration (SSI) add-in.
- Do not click on the "+" button, as this creates a normal (non-recurring) event.
- Instead, click directly on "Save this item" or search for the object to link it to and then save it.
See Also
KBA 3064098 - Error "CC-024: Single event to series conversion is not supported" at Outlook Server Side Integration
Keywords
recurring visit, outlook integration, c4c calendar, CC-024 error, individual event to series conversion, recurring appointment creation, visit management, server-side integration, sync issue, calendar issue, outlook add-in, production environment , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem
Product
Attachments
| Screenshot 2025-10-29 124735.png |
SAP Knowledge Base Article - Public