Symptom
The following article provides guidance on troubleshooting scenarios where the document generation or e-signature step is not being assigned to a candidate. There can be several reasons why the e-signature step is not assigned to a candidate. In this article, we’ll cover the most common causes of document generation failures and explain how these can be self-resolved.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as the external user
- Click on “Your Onboarding Checklist”
- Complete E-Signature Task is locked
Cause
Cause 1: Identify User Validation Failure
- Go to BPE: Monitor Processes
- Click on Filter
- Under Variable add: OnboardingProcessId=<Enter the candidates process id>
- Notice the section under “Activities”
If you see the “View Document Create Errors”, under Activities, this would indicate that there is a data validation issue with the user (onboardee) who is impacted due to which the Document Flow/E-Signature is not successfully triggered.
Cause 2: Identify Process Validation Failure
- Go to BPE: Monitor Processes
- Click on Filter
- Under Variable add: OnboardingProcessId=<Enter the candidates process id>
Notice the section under “Jobs”:
You can view the error under the “Jobs” section. This indicates that the Document Generation or E-Signature process failed due to system-level issues such as PFS Server Failure, BPE Server Issues, or instances where BPE was unable to process a backend event, among others.
Resolution
Solution 1: Resolve User Validation Errors
In this section, we will show steps on resolving the errors related to User Validation Error. Below is an example of how the error appears' in the Business Process To-Do. The key points to note have been highlighted for your reference in the below screenshot:
As an Error Flow Admin, you can view the specific error details within the Business Process To-Do section. Here are a few self-service steps you can follow to resolve document flow issues based on the error codes:
- If the status code is 400, this indicates that the form template is invalid/corrupted.
To correct the issue, go to Maintain Onboarding and Offboarding Document Template, reupload the template and preview it successfully. If you can preview it successfully, you can simply restart the task from the business process to-do. - If the status code is 401, this indicates that the issue is with PFS Authentication. Instance is not successfully authenticated with the PFS URL configured.
To correct this issue, validate if the PFS User Id is associated with the PFS URL or if the PFS URL is associated to the correct company id. Try to login to the PFS URL. If you can successfully login, resave the PFS credentials in Provisioning under Company Settings. If you cannot successfully login, reset the Password associated with the P-User and then login to PFS before saving the credentials in Provisioning.
If you notice that the PFS URL is incorrectly associated or the P-User is incorrectly associated in provisioning, please feel free to reach out to the Cloud Ops Support via Cloud Ops Portal. - If the status code is 403, the issue is with PFS Migration Failure.
To correct the issue, please create a ticket with SAP Product Support. - If the status code is 405, the URL might be configured incorrectly in provisioning.
To correct the issue, please check the URL configuration in Provisioning under Company Settings. Make sure there are no space or invalid characters. - If the status code is 500, this would indicate that there is an issue with the placeholder validation with a specific form.
To correct the issue, we need to identify the mapping which has been done between the Custom Form and Candidate Information via placeholders.- Go to Manage Data > Create New > Document Template Mapping Preview.
- Enter Document Template Mapping Preview ID (Any value can be entered), enter impacted onboardee’s Process ID and under Document Template enter affected template name (which was shown in BPE error).
- See which placeholder has unwanted characters such as spaces, tab spaces (\t), or special characters.
In the above image, as you can see the placeholders “Relationship1”, “Proportion1”, “Gender” and “MaritialStatus” have invalid characters due to which the Document Generation failed with error code 500.
Note: The above image is not how the results are shown in Document Template Mapping Preview Page. You can use any XML Beautifier to get similar results. - Once the placeholders with invalid characters are identified: Go to Maintain Onboarding and Offboarding Document Template, open the mappings for the impacted form and identify the target field
- If this is mapped to a standard HRIS Elements (Such as Job Information > Business Unit), you can correct the information from Onboarding Dashboard > Actions > New Hire Data
If this is mapped to a custom MDF Object (Custom Object configured in either New Hire Template or in Additional Data Collection), you can correct the information from Manage Data by searching for the custom object associated with the candidate. - After the affected placeholder is corrected, you can restart the Business Process Error from the to-do panel.
- Go to Manage Data > Create New > Document Template Mapping Preview.
- Status Code 503, this would indicate that the application/document generation service is unavailable due to server issues.
IMPORTANT NOTE: If your instance is migrated from PFS Neo Environment to Cloud Foundry, the error codes are similar to the above explanation.
- Error code 401 and 405 indicate that there might be an issue with the Service User Authorization during Document Generation.
- Error code 404 indicates that the templates are not available in the instance.
- Error code 500 and 503 are the same as explained earlier.
Solution 2: Resolve Process Validation Errors
In this section, we will show steps on resolving the errors related to Process Validation Error
- Go to BPE: Monitor Processes
- Click on Filter
- Under Variable add: OnboardingProcessId=<Enter the candidates process id>
- Copy the Process instance id as highlighted above.
- Go to BPE: Manage Process Task
- Filter using Process Instance Id and paste the value as copied in step 4
- Select the Process Task and click on “Restart Task”
- If the issue is caused due to intermittent server issues/temporary glitches, the task will be successfully restarted. If this is due to backend issue, you will receive an application error.
- If you receive an application error, you can reach out to SAP Product Support
Frequently Asked Questions:
- Can we use the same troubleshooting guide if Compliance E-Signature (Country or i9 compliance) is not triggered?
Answer: Yes, you can follow the same steps. The only difference would be the way you identify the process instance Id in BPE
i. Go to BPE: Monitor Processes
ii. Click on Filter
iii. Under Variable add: userName=<Enter the candidates username>
documents.ComplianceDocumentWorkflow Process Definition Id contains the E-Signature details for compliance tasks. - We are getting Error Code 401 after the instance was refreshed.
Answer: After the refresh is completed, the PFS credentials are copied from the source instance to the target instance. Due to which the error code 401 is shown. We need to ensure that the target instance is configured with its own PFS credentials. - Do we still have to reset the PFS Password every 6 months?
Answer: If your instance is already migrated from Neo to Cloud Foundry (CF), there is no need to reset/resave the PFS credentials in Provisioning. This is only applicable to those instances where the migration is incomplete.
- If the instance is already completed for PFS Migration, what should be the next action?
Answer: There is no further action required. The complete dependency of the PFS URL will be null after the migration is completed eliminating the need to maintain the credentials in Provisioning or resaving the credentials every 6 months. - We never used PFS before, should we request for a new one now?
Answer: You should only request for a new URL if your instance is not yet migrated from Neo to CF. Most of the DCs are migrated to CF so please reach out to Cloud Ops support to verify if the migration is completed before requesting for a new one.
See Also
- If you have any queries, please feel free to post it here: Common troubleshooting steps to identify and resolve issues related to Document Flow in Onboarding
Keywords
Complete Your E-Signature, Compliance E-Signature, Custom Signature, Document Flow, document generation, E-Signature, I-9 E-Signature, onboarding, Onboarding Document Flow, signature, 401, 403, 500, HTTP Status Code 500, Status Code, odata/PDF, Error creating document , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , LOD-SF-OBX-ESN , E-Sign Onboarding , Problem
Product
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SAP Knowledge Base Article - Public