Symptom
Duplicate order numbers are being raised when an order is submitted to the reported internal system, the system identifies it as a duplicate and prevents synchronisation and processing.
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Create a new quote in SAP CPQ.
- Check if the quote was duplicated in the CPQ system.
- If the quote reference was previously raised, the quote cannot be used or progressed into the clients external SAP system.
Cause
Known bug in SAP CPQ due to migration from engine 1.0 to engine 2.0.
Resolution
- A fix for this issue is tentatively scheduled for release in version 2605.
- There is a workaround for the CPQ internal engineering team to update the quote numbers. This is only a temporary measure until the fix is completed.
- Monitor updates to this KBA for any changes to the fix version.
See Also
- Refer to: Bug in Application
- Refer to: Known Issues in SAP CPQ
- Refer to: CPQ Release Notes
Keywords
duplicate order numbers, sap p82, sap cpq, quote reference, order synchronization, manual processing, known bug, engine migration, cpq version 2602, order clashes, quote numbers , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public