Symptom
Error message "No authorization for the action" appears upon triggering a "New Run" for generic and custom reports in "Run Statutory Reports" application.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Access APP "Run Statutory Reports".
- Set the filter values and click on GO.
- Select a reporting task.
- Select the report generation activity.
- Click the "New Run" button.
Cause
The issue is caused by a missing catalogue.
Resolution
-
Assign business catalogue "SAP_FIN_BC_SRF_RUN_PC" to the Business User. Perform the "New Run" after ensuring the catalogue is maintained.
- Refer to Generic Business Catalogs | SAP Help Portal and Generic Report Category | SAP Help Portal for more information.
See Also
Keywords
authorization error, custom report, sap s/4hana cloud public edition, YY1, SAP_FIN_BC_SRF_RUN_PC, missing catalogue, No authorization for the action , KBA , FI-LOC-SRF-RUN , Runtime , FI-LOC-SRF-DEF , Design Time , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public