Symptom
It is not possible to add "Account External ID" on Opportunity TI via Adaptation Mode.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales then Opportunities WoC.
- Start Adaptation mode.
- Click on header pencil.
- On adaptation menu, drill down Opportunities.
- Click Add > Fields.
- Scroll down until find "Customer" field.
- Click on blue arrow to drill down.
- At the bottom click on "Default Object Identifier Mapping" blue arrow.
- The "Account External ID" is not available because it is not PSM released.
Cause
The "Account External ID" is already PSM released for the Opportunities screen, but it is intended to be used in the Opportunity OWL screen.
For the Opportunity header, it is not PSM released and it will not be enabled for the Opportunity TI since it is already available in the OWL.
Resolution
Please use the "Account External ID" from Opportunities OWL screen. For that, please follow:
- Go to Sales > Opportunities.
- Go to User Menu > Start Adaptation.
- Click on pencil.
- Click on Add > fields.
- Select Customer.
- Select Default Object Identifier Mapping.
- Select Remote Object ID.
- Optional: rename Remote Object ID label to External ID and drop field next to Account.
- Usually Sign off and Sign on helps to expose the updates including showing the ID in the worklist.
Keywords
PSM-release, PSM-released, opp, thing inspector, object working list , KBA , LOD-CRM-ACC , Account , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public