SAP Knowledge Base Article - Public

3675363 - Account External ID not available for Opportunities

Symptom

It is not possible to add "Account External ID" on Opportunity TI via Adaptation Mode.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales then Opportunities WoC.
  2. Start Adaptation mode.
  3. Click on header pencil.
  4. On adaptation menu, drill down Opportunities.
  5. Click Add > Fields.
  6. Scroll down until find "Customer" field.
  7. Click on blue arrow to drill down.
  8. At the bottom click on "Default Object Identifier Mapping" blue arrow.
  9. The "Account External ID" is not available because it is not PSM released.

Cause

The "Account External ID" is already PSM released for the Opportunities screen, but it is intended to be used in the Opportunity OWL screen.

For the Opportunity header, it is not PSM released and it will not be enabled for the Opportunity TI since it is already available in the OWL.

Resolution

Please use the "Account External ID" from Opportunities OWL screen. For that, please follow:

  1. Go to Sales > Opportunities.
  2. Go to User Menu > Start Adaptation.
  3. Click on pencil.
  4. Click on Add > fields.
  5. Select Customer.
  6. Select Default Object Identifier Mapping.
  7. Select Remote Object ID.
  8. Optional: rename Remote Object ID label to External ID and drop field next to Account.
  9. Usually Sign off and Sign on helps to expose the updates including showing the ID in the worklist.

Keywords

PSM-release, PSM-released, opp, thing inspector, object working list , KBA , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications all versions