Symptom
The fine-tuning activity "Business Task Management for Overdue Task Activity for Processor" is active to send e-mails to the Processor of a Task.
When manually creating the Tasks from an Opportunity via UI, only one e-mail is created as expected. However when creating a Task related to an Opportunity via OData, duplicate e-mails are sent.
Environment
SAP Cloud for Customer
Cause
When creating a Task for an Opportunity via OData, separate POST calls needs to be done. One for the Task creation (TasksCollection) and another one for the Task association with the Opportunity (TasksBTDReferenceCollection).
Due to that the fine-tuning "Business Task Management for Overdue Task Activity for Processor" responsible for sending those e-mails, is triggered twice. Because the creation and association is happening separately.
While when manually creating a Task inside the Opportunity screen, the creation and association happens simultaneously, making the e-mail to be triggered one.
Resolution
This is the system expected behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
email, mail, BTM, multime times, outlook, gmail, opp, activity, activities , KBA , LOD-CRM-ACT , Activities , Problem
SAP Knowledge Base Article - Public