Symptom
- On rehire welcome email, the username is displayed as the old username instead of the personal email address for rehire on old employment.
- This issue occurs when the rehire coordinator selects an older past employment for "rehire with old employment" instead of the latest past employment.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Initiate the rehire candidate from RCM.
- Complete the "Personal Data Collection" step.
- Proceed to the "Onboarding Rehire Verification" step.
- Select the candidate as "rehire with old employment".
- Maintain the personal email in the rehire data review page.
- After completing the rehire verification, the rehire candidate receives the welcome email.
- However, the username in the email is displayed as the old username instead of the personal email address.
Cause
The issue occurs when a user has multiple past employments, and the rehire coordinator selects an older past employment for "rehire with old employment" instead of the latest past employment.
Resolution
The engineering team will evaluate this enhancement. You can follow this KBA to get the latest update information.
Workaround:
If need to update candidate's username, please follow the steps outlined below:
- Navigate to Admin Center -> Manage Login Accounts.
- Search for the affected user.
- Change the username to new personal email and login type as PWD.
- Reset the password of the external user.
- Send this link to the candidate to log in to the instance: https://performancemanager.successfactors.com/login?company=xxxxxx&username=abc%40abcmail.com&pm_product_name=ONB (if the company id is xxxxxx and personal email is abc@abcmail.com)
Keywords
rehire with old employment, rehire welcome email, old username, personal email, onboarding, sap successfactors onboarding, username change, rehire verification, multiple past employments, rehire coordinator, email services, manage login accounts,OBX-40887 , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , LOD-SF-OBX-EML , Notifications , Product Enhancement
SAP Knowledge Base Article - Public