Symptom
- Issue with the "Query Browser" app where analytical queries cannot be opened for analysis.
- Error message displayed as "Sorry, the app could not be opened. The navigation target ‘#AnalyticQuery-analyze?bsa_query=2CCARNANLYTSRETSO&sap-app-origin-hint=’ of the app could not be resolved. This can be caused, for example, by an incorrect content configuration, an incorrect or missing role assignment, or because your current device is not supported."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Query Browser app.
- Select any entry and try to access
- Observe the error message as "Sorry, the app could not be opened. The navigation target ‘#AnalyticQuery-analyze?bsa_query=2CCARNANLYTSRETSO&sap-app-origin-hint=’ of the app could not be resolved. This can be caused, for example, by an incorrect content configuration, an incorrect or missing role assignment, or because your current device is not supported."
Cause
The IAM App "WDA0182_TRAN" is not active in the business role assigned to the user.
Resolution
To resolve the follow the below steps:
- Assign the business catalog (SAP_CORE_BC_EXT_AQA_PC) to the user role
- Click on IAM App tab
- Search for IAM App "WDA0182_TRAN"
- Select and click on "Activate" to activate the the IAM App "WDA0182_TRAN"
- Save the Role
See Also
Refer to: How to Activate or Deactivate IAM Apps of Type App Authorization Variant | SAP Help Portal.
Keywords
query browser app, analytical queries, navigation target error, sap s/4hana cloud, app configuration, role assignment, IAM app activation, WDA0182_TRAN, business catalog, business role, error message, troubleshooting, Sorry, the app could not be opened, Query Browser , KBA , BC-SRV-APS-IAM , Identity and Access Management , BC-SRV-APS-EXT-AQD , Fiori based Query Designer , Problem
SAP Knowledge Base Article - Public