SAP Knowledge Base Article - Public

3676708 - Service Task Disappears When the Generate Period Plan Date is Changed

Symptom

The service task disappears when the task’s end date is modified in the Generate Period Plan.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Project Management work center.
  2. Search for the Project XYZ.
  3. Select "Edit".
  4. Locate the task, e.g.,XYZ1.
  5. Create a service.
  6. Edit the Period Plan for a week ( for e.g., 14-07-2025 to 18-07-2025).
  7. Generate the Period Plan.
  8. Verify that the task is generated in the Resource Profile.
  9. Return to the Project XYZ
  10. Edit the service.
  11. Change the end date in the Generate Period Plan ( for e.g., 14-07-2025 to 16-07-2025).
  12. Observe that the task disappears from the Resource Profile.

Cause

  • The system attempts to redistribute planned hours among available dates. If the end date is set to a past date, the system does not distribute the hours, as resource planning does not function for past dates.

Resolution

  1. Ensure that the end date in the Period Plan is set to a future date to display planned hours.
  2. Use the "Redistribute planned hours for or Edit" button to modify the hours as needed. 

Note :The resource planning is designed to function only for future dates.

Keywords

task disappears, service plan hour date, period plan, resource profile, planned hours, future date, past date, resource planning, redistribute hours, task missing, generate period plan , KBA , SRD-HR-RPM , Resource Pool Management , Problem

Product

SAP Business ByDesign all versions