SAP Knowledge Base Article - Public

3676815 - Individual customer can be accessed by any user and can not be restricted by any business role.

Symptom

Business users with the role are able to view individual customer despite access restrictions being configured to limit read and write access.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log in with the user which the restriction rule is being configured to limit read and write access 
  2. Navigate to the individual customer section and search for ID 
  3. Observe that the user is able to view this individual customer despite the configured access restrictions.

Cause

If an individual customer has a 1015 (00000000000000000000000000000000) ACL entry and the business partner (in this case is the individual customer) has two role: Customer and Contact Person ,every user (independent how the restrictions are tailored) has access to the individual customer + contact person. 

Resolution

  1. Navigate to the Data Protection and Privacy work center.
  2. Select the "Personal Data Removal" option.
  3. Query all business partners and locate customer ID.
  4. Identify the contact person role associated with the customer ID.
  5. Remove the contact person role if it is not required.
  6. Save the changes and verify whether the access restriction is now functioning as expected.

Keywords

access restriction, individual customer, business role, homeless, ACL entry, contact person role, restriction rule, Account, unrestricted access, Data Protection and Privacy work center, personal data removal. Account, Business partner. , KBA , LOD-CRM-ACC-PRI , Private Account (Customers) , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer core applications all versions