SAP Knowledge Base Article - Public

3677051 - Customer Merge And Sales Support Block Functionality

Symptom

When performing a Customer Merge, the result Status is "Merge Completed - Realignment Failed"

Environment

Cloud for Customer

Reproducing the Issue

  1. Go to the Customer Merge WC.
  2. Create a new Merge and select the desired Customers.
  3. Choose the Surviving Record and the Record that should be consumed during the merge.
  4. Complete the Merge.
    • Observe that the Merge Status shows: "Merge Completed – Realignment Failed."
  5. Navigate to the “Result Log” tab.
    • You will see a log entry with errors, open this log.
  6. Go to the “Results” tab within the log and click “Expand All.”
  7. Review the error message: "Sales support block is set for party ID #AccountID with role Account in master data." 

Cause

When performing a Customer Merge, if the Sales Support Block is active for one of the customers, users are restricted from creating any documents such as Leads, Opportunities, Visits, or Activities for that account.

Resolution

This is the standard behavior of the system.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.

An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:

See Also

  • KBA 2635924 - Sales Support Block Functionality
  • KBA 3391931 - Error "Sales support block is set for party ID XXXXXX with role Account in master data" for transactional documents such as Leads, Opportunities, Activities when created from Account.

Keywords

Account Merge, Customer Merge, Merge, Sales Data, Sales Support Block, Merge Completed, Realignment Failed, Merge Completed – Realignment Failed , KBA , LOD-LE-BP-MRG , Business Partner Merge , Problem

Product

SAP Cloud for Customer core applications 2508