Symptom
When performing a Customer Merge, the result Status is "Merge Completed - Realignment Failed"
Environment
Cloud for Customer
Reproducing the Issue
- Go to the Customer Merge WC.
- Create a new Merge and select the desired Customers.
- Choose the Surviving Record and the Record that should be consumed during the merge.
- Complete the Merge.
- Observe that the Merge Status shows: "Merge Completed – Realignment Failed."
- Navigate to the “Result Log” tab.
- You will see a log entry with errors, open this log.
- Go to the “Results” tab within the log and click “Expand All.”
- Review the error message: "Sales support block is set for party ID #AccountID with role Account in master data."
Cause
When performing a Customer Merge, if the Sales Support Block is active for one of the customers, users are restricted from creating any documents such as Leads, Opportunities, Visits, or Activities for that account.
Resolution
This is the standard behavior of the system.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
See Also
Keywords
Account Merge, Customer Merge, Merge, Sales Data, Sales Support Block, Merge Completed, Realignment Failed, Merge Completed – Realignment Failed , KBA , LOD-LE-BP-MRG , Business Partner Merge , Problem
SAP Knowledge Base Article - Public