SAP Knowledge Base Article - Public

3677135 - Completed On Date blank for step in Onboarding Dashboard - Onboarding

Symptom

  • The "Completed On" field is not visible when accessing the onboarding dashboard as a hiring manager.
  • The issue occurs under the "Provide Personal Data" task or "New Hire Data Review" task in the onboarding dashboard.
  • The field is visible to admin users but remains blank to hiring managers.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Proxy as the hiring manager role.
  2. Navigate to the onboarding dashboard and select a candidate.
  3. Go to "Tasks" under "Data Collection" and click on "Provide Personal Data".
  4. Observe that the "Completed On" date field is blank.
  5. Although the PDC step has been completed

Cause

  • The field "lastModifiedDate" in the process task object has its visibility set to "Not Visible".

Resolution

  1. Navigate to "Configure Object Definition".
  2. Select "Process Task".
  3. Click "Task Action" and choose "Make Correction".
  4. Locate the field "lastModifiedDate" and click "Details".
  5. Change the visibility setting of "lastModifiedDate" to "Read Only".
  6. Save the changes.
  7. Perform an OData refresh.
  8. Verify that the "Completed On" field is now visible for the hiring manager.

See Also

Keywords

onboarding dashboard, completed on date, invisible field, hiring manager, process task object, lastModifiedDate, read-only visibility, OData refresh, blank, Completed On, NHDR, PDC. , KBA , LOD-SF-OBX-DBD , Dashboard , Problem

Product

SAP SuccessFactors Onboarding 2505 ; SAP SuccessFactors Onboarding 2511