Symptom
When you edit an Extension Field in a Cancellation Customer Invoice which is already Released, after saving, the system generates a new Output for that Customer Invoice.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Open the Invoice Documents view.
- Find and Open Cancellation Customer Invoice ABC (Where ABC Represents the ID of a Cancellation Invoice which is already Released).
- Provide a new value for Extension Field DEF (Where DEF Represents the Extension Field ID).
- Save the Customer Invoice.
- Close and Re-open Customer Invoice ABC.
- Click the View All button.
- Navigate to the Output History tab.
In the Output History, a new Output was genarated after the change to Extension Field DEF was saved.
Cause
Changes to Extension Fields are considered output-relevant to the system and because of this, trigger a new Output when saved, even for Cancellation Invoices which are already Released.
Resolution
This is the expected system behavior. We recommend avoiding changes to Extension Fields which are present in already Released Customer Invoices.
Keywords
KBA , AP-CI-CI , Customer Invoice , How To
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