SAP Knowledge Base Article - Public

3677982 - Live Direct Connection to SAP HANA fails due to the local network access (LNA) specification using Google Chrome 142 and later

Symptom

  • Access to the following live data sources below hosting in your local network will be blocked after upgrading Google Chrome 142 when using a DIRECT/CORS live data connection in SAP Analytics Cloud (SAC): 
    • SAP HANA on-premise
    • SAP Universe or WebI document

  • The following error appears in SAC:
    • When creating Live Direct Connection to SAP HANA:
      We couldn't connect to your HANA system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see our troubleshooting page.
    • When creating or opening a story/model based on Live Direct Connection to SAP HANA:
      Sorry, we couldn’t authenticate you. Please ensure your credentials are valid. 

  • The following error also appears in the console log of Chrome Browser:
    Access to fetch at 'https://<HANA Host:port>/sap/bc/ina/service/v2/GetServerInfo' from origin 'https://<SAC Domain>' has been blocked by CORS policy: Permission was denied for this request to access the `unknown` address space.
  • For Live Direct connection to SAP BW or SAP S/4HANA on-premise hosting in your local network , one pop-up will appear to enable to allow the access:


Environment

  • SAP Analytics Cloud Enterprise
  • SAP HANA On-Premise
  • Google Chrome 142

Reproducing the Issue

  1. On-premise SAP HANA system is configured for live data connections that use the direct connection type as per Live Data Connection to SAP HANA On-Premise Using a Direct Connection
  2. On SAC find "Connections" on side navigation > Add Connection
  3. The Select a data source dialog will appear.
  4. Expand Connect to Live Data and select SAP HANA.
  5. In the dialog, enter a name and description for your connection.
  6. Set the connection type to Direct.
  7. Add your SAP HANA host name, and HTTPS port.
  8. Create a model from this connection.
  9. The error appears.

Cause

Local network access (LNA) specification implemented in Google Chrome.

Resolution

Browser Side Solution

  • Option 1: Disable LNA checks in your Chrome browser chrome://flags/#local-network-access-check

    • It requires to restart Chrome browser to make it affect.
    • It will affect all domains globally.

  • Option 2: add your SAC URL (https://<SAC Domain>) into in your Chrome browser chrome://settings/content/localNetworkAccess
    • This could be accessed and done only when LNA Checks is not disabled.
    • Using this option, you don't need to restart browser but just reload the browser page.

Note: Chrome enterprise users can also have their administrators set an enterprise policy to enable lna for them, rather than having to change every single browser.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, Chome, 142, PNA, LNA, local, Network, Access, HANA , KBA , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , LOD-ANA-ML , SAC Modelling , LOD-ANA-LDC-UNV , SAC Live Data Connection Universe , LOD-ANA-DES , Story Design & Visualizations , Problem

Product

SAP Analytics Cloud 1.0

Attachments

Pasted image.png