SAP Knowledge Base Article - Public

3678185 - Error message is in Web Service Message Monitoring when E-Mail is forwarded to E-Mail Channel

Symptom

  • Error happens when an e-mail is forwarded to an E-mail Channel to create a ticket
  • Error message: E-mail address XXX is invalid

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite

  • E-mail that is received has multiple recipients (e.g. 1 recipient in To and 2 recipients in CC)
  • Recipient has a special character in a name (e.g. "üß X" <x.uss@abcd.com>)
  1. Forward the e-mail to an E-mail Channel to create a ticket
  2. Go to the Service work center
  3. Go to the Tickets view
  4. Search for a ticket created by the incoming e-mail
  5. No ticket found
  6. Go to the Administrator work center
  7. Go to the Web Service Message Monitoring
  8. Search for the message for the incoming e-mail

Result: It fails with an error message.

Cause

SAP Cloud for Customer system uses a semicolon (;) to separate email addresses. If e-mails are separated with a comma, the system recognises a name as an e-mail address (e.g. "üß X" is considered as an e-mail address) and the error occurs.

Resolution

Separate e-mails with a semicolon instead of a comma.

Keywords

email address, invalid, emailserviceRequestIn, Lotus Notes, semicolon, comma , KBA , LOD-CRM-SC-EML , Email , Problem

Product

SAP Cloud for Customer core applications all versions