SAP Knowledge Base Article - Public

3678564 - Unable to logon to SAP Analytics Cloud or Datasphere when using Microsoft Edge

Symptom

When attempting to logon to SAP Analytics Cloud or Datasphere using Microsoft Edge the logon page just hangs and does not finish loading.  It is not yet known all the versions of Edge that are affected.  (142.0.3595.53 is known to be affected).  Chrome and Firefox work fine.

Environment

  • SAP Analytics Cloud
  • Microsoft Edge 142.0.3595.53 (May be other affected versions)

Reproducing the Issue

  1. Launch Microsoft Edge
  2. Attempt to logon to SAC or Datasphere

Cause

The issue was caused by an undocumented update to how Microsoft Edge service workers handled redirects.

Resolution

A fix has been applied to all tenants, however you may need to upgrade your version of Microsoft Edge as well.  In testing we found the following versions were still affected:

143.0.3650.66 - fails
143.0.3650.80 - fails
143.0.3650.96 - works
143.0.3650.139 - works
144.0.3719.82 - works

So if you are still encountering the issue - please update your version of Microsoft Edge to one of the updated versions or higher.

Keywords

edge, fail, failure, timeout, stuck, hang , KBA , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0