Symptom
- An error occurs when attempting to insert a record with a date value of "9999-12-31" into a custom table in SAP CPQ.
- The error message displayed is: "The date value 12/31/9999 12:00:00 AM is out of range. Must be between 0001/01/02 and 9999/12/30."
Environment
SAP Sales Cloud CPQ
Reproducing the Issue
- Create a custom table with a date-type attribute.
- Attempt to insert a record using the API example:
- /custom-table/v1/customTables/custom_items/entries
- "contractEndDate": "9999-12-31"
Cause
This is an expected behavior.
Resolution
To address the issue, follow these steps:
- Insert Date Value:
Insert the value 30.12.9999 into the relevant date field. Ensure that this date falls within the acceptable range, which is between 0001/01/02 and 9999/12/30. - Set Random Time Zone:
Assign a random time zone.
Keywords
date value out of range, custom table, sap cpq, 9999-12-31, date-type attribute, api error, update issue, date range error, expected behavior, custom table error, sap sales cloud , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ all versions
SAP Knowledge Base Article - Public