Symptom
Integration of Service Order from SAP S4HANA On-premise to SAP Service Cloud Version 2 is enabled, but registered product/equipment is not transferring from S4 to V2. Equipment data is available in the inbound V2 payload but is not linked to the V2 Service Order.
Environment
SAP Sales & Service Cloud Version 2 Integration with SAP S4HANA
Reproducing the Issue
- Create a Service Order in SAP S4HANA On-premise with the registered product.
- On creation, integration is triggered to SAP Service Cloud Version 2.
- SAP Service Cloud Version 2 receives the equipment in the payload.
- Service Order is successfully created in SAP Service Cloud Version 2; however, the equipment is not linked.
Cause
- The registered product with external ID sent in the incoming payload does not exist in the system. The integration layer attempts to find the internal ID by matching the external ID sent in the payload. As the integration layer does not find the match, it does not update the Service Order with the equipment.
- Older version of service order replication iflow is used
Resolution
- Ensure all registered products are replicated from SAP S4HANA On-premise to SAP Service Cloud Version 2 before using them in Service Orders.
- Verify that the external ID of the registered product exists in SAP Service Cloud Version 2 and matches the data sent in the payload.
- Perform a test replication to confirm that the registered product is successfully linked to the Service Order.
- Ensure to upgrade the iflow to latest version 1.2.7 atleast. A change to handle multiple registered products has been introduced.
Keywords
sap s4hana, sap service cloud version 2, registered product, equipment, integration, service order, replication, inbound payload, external id, internal id, linking issue, troubleshooting , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem
Product
SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public