Symptom
After migration to the latest People Profile, the 'View all' functionality does not display all one-time payment records.
Only data up to 2024 is visible, while in the legacy design instance system shows all the previous records.
Environment
SAP SuccessFactors Employee Central
SAP SuccessFactors Employee Profile
Reproducing the Issue
- Log in to the instance;
- Navigate to the user profile;
- On Compensation Information, click on: One Time Payment > View All.
- You see that only recent records are visible and there is no record from the past few years.
However, when you perform the same steps in an instance with the legacy people profile view you can verify that details from 2015, for example are visible for the same employee.
Cause
This is expected behavior. In the latest People Profile for One-Time Payment, the summary card view is restricted to a limited number of rows (approximately 20).
Resolution
To see all the one-time payments you can click on "Edit" in the One-Time Payment section. Then you will be able to view all available pay components.
See Also
Keywords
all, pay component non recurring, pay component, not all one time payment, one-time payments, non recurring pay component, view all, one time, latest people profile, view all functionality, one-time payment records, employee central, compensation, summary card view, performance issue, edit functionality, full profile, legacy profile , KBA , LOD-SF-EP-FPP , People Profile - Full Profile , Problem
SAP Knowledge Base Article - Public