Symptom
- The "correct my personal data" button is not visible during I9 section 1.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Log in as candidate
- Open I-9 Section 1
- "Correct my personal data" button is not available
Cause
Onboarding Compliance Metadata Sync Job has not been completed in provisioning since 2H 2025 release
Resolution
- Navigate to provisioning
- Monitor Jobs
- Select job type Onboarding Compliance Metadata Sync Job
- Run the job
- If job is not available here you will need to create and schedule to run the job. Please see guide for details.
- Once job is completed, please restart onboarding for the candidate so new compliance updates are triggered.
- Other prerequisites for the button Correct My Personal Data to appear
- Valid External User
- External User is not yet hired
- No MPH Draft or MPH workflow exists
- I9 Section 2 is not completed
See Also
Keywords
correct my personal data, button missing, i9 section 1, OBX-37593, compliance form, USCIS Form I-9, Form I-9, Onboarding Compliance Metadata Sync, compliance metadata sync job , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
Product
SAP SuccessFactors Onboarding 2511
SAP Knowledge Base Article - Public