SAP Knowledge Base Article - Public

3680263 - Correct My Personal Data Button Missing During I9 Section 1

Symptom

  • The "correct my personal data" button is not visible during I9 section 1.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Log in as candidate
  2. Open I-9 Section 1
  3. "Correct my personal data" button is not available

Cause

Onboarding Compliance Metadata Sync Job has not been completed in provisioning since 2H 2025 release

Resolution

  1. Navigate to provisioning
  2. Monitor Jobs
  3. Select job type Onboarding Compliance Metadata Sync Job
  4. Run the job
  5. If job is not available here you will need to create and schedule to run the job. Please see guide for details.
  6. Once job is completed, please restart onboarding for the candidate so new compliance updates are triggered.
  7. Other prerequisites for the button Correct My Personal Data to appear
    1. Valid External User
    2. External User is not yet hired
    3. No MPH Draft or MPH workflow exists
    4. I9 Section 2 is not completed

See Also

Keywords

correct my personal data, button missing, i9 section 1, OBX-37593, compliance form, USCIS Form I-9, Form I-9, Onboarding Compliance Metadata Sync, compliance metadata sync job , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem

Product

SAP SuccessFactors Onboarding 2511