Symptom
- Custom workflow template configured with multiple approval steps (second, third, fourth approvers) where approvers receive Todo items but no email notifications
- Only the first step approver receives both email notifications and Todo items correctly
- Multi-Approval Workflow: Email for First Approver, To-Do Only for Subsequent Approvers
- Standard workflow templates function properly with all approvers receiving notifications
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central - Workflows
- SAP SuccessFactors Employee Central - Document Generation
Reproducing the Issue
- create WorkflowEmailConfiguration under manage data
- configure Manage Workflow Email Configuration
- Create a custom workflow notification.
- Assign multiple approvers to the workflow.
- Trigger the workflow and observe that only the first approver receives the notification.
Note:
- Step 1 approver gets both email + ToDo,
- Step 2, 3, 4 approvers get only ToDo, no email notification,
- Standard workflow templates work fine (so the system email configuration itself is fine).
Cause
- Configuration issue
User only switch on Manage Workflow Email Configuration for Workflow Initiated, so only the first step approver can receive email.
Resolution
- Go to Admin Center Manage Workflow Email Configuration and create a new configuration
- Turn email notifications on or off for the relevant recipients at each workflow action.
- Select Workflow Email Configuration: Maternity Leave
- Please switch on the email notification for Workflow Approved - current approver, which means it will send email to step approver when approve the workflow.
For example: when a workflow step is approved, you want the initiator and current approver to be notified. You can define the configuration for Workflow approved Action as follows: If you only want to modify an existing configuration, select it from the configuration dropdown list. Example for custom workflow : Maternity Leave:
Example:
FAQ - Additional Information
Q) Where can I get Guide?
A) Guide: Employee Central Workflows: Implementation and Administration
Chapter:
- Setting Up Custom Workflow Notifications
- Available E-mail Templates for Employee Central Workflows
- Workflow Action Contributor Notification : Sends email notification when the workflow is initiated
- Workflow Comment Posted Notification: Sends email notifications when a comment is posted on a workflow.
- (Optional) Copy the template if you need templates in several languages.
Please find this information documented in a blog: EC Custom Workflow Email Notifications
NOTE: This is a custom solution and therefore it is outside the scope of SAP Cloud Product Support. If customer raises a case, please direct them to the above blog and if they run into any difficulty, they need to reach out to their partner /Professional Services team who will be able to assist them further.
See Also
- 2793226 - Standard Notification being Triggered instead of Customized - SAP SuccessFactors Employee Central
- 3567765 - Workflow contributors are not receiving any E-mail Notifications When a Comment is Posted on a Workflow
- 2579208 - EC Email Notification Tags
- 2463478 - Configuring EC workflow notification templates
- 2580212 - How To Enable or Disable Manage Workflow Email Configuration
- Blog: https://community.sap.com/t5/human-capital-management-blog-posts-by-members/ec-custom-workflow-email-notifications/ba-p/13385247
Keywords
INC16420320, Manage Workflow Email Configuration , Workflow Email Configuration, WorkflowEmailConfiguration , Manage Data, step , approver, Standard Workflow Notifications, Document Generation, Language, Workflow Email Notifications , KBA , LOD-SF-EC-WFL-CUS , Custom Workflow Notifications , LOD-SF-EC-WFL-REQ , My Pending Requests, ToDo's & Mass Approvals , Problem
Product
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