SAP Knowledge Base Article - Public

3681310 - error during i-9 reverification migration job - cannot find user by id

Symptom

  • An error occurs during the I-9 reverification migration job run in Super Admin.
  • Records failed due to the error message: "Cannot find user by id …".
  • Cannot find user by id.

Environment

SAP SF Onboarding 1.O

Reproducing the Issue

  1. Log in to the onboarding super admin account.
  2. Run the I-9 Audit Trail Migration job.
  3. Check the I-9 Audit Trail Migration report status, and observe failed records due to the error "Cannot find user by id".

Cause

User IDs in BizX are not updated correctly; both incorrect and actual user IDs remain unchanged.

Resolution

  1. Verify the user list provided by the customer.
  2. Check if same user Id is present in the below process or not:

    • First open User Role Search in BizX
    • Find user by name
    • Take USERNAME from the page
    • Open Data Inspector
    • Select the Table_USERS_SYSINFO for Entity and use filter as Username equal/contains USERNAME from User Role Search
    • Scroll to the right and notice user Id
    • This userID should be provided in RITM.

  3. Obtain approval to run the script that updates the user IDs at the database level.
  4. Create a service request to execute the script for updating the user IDs.
  5. Ensure the engineering team executes the script to update the user IDs at the database level.
  6. Verify the system functionality post-execution to ensure the migration is completed successfully.

Note:

If you do not have super admin access, please reach out to SAP Support team.

See Also

Keywords

Form i-9 audit trail migration error, I-9 Data Migration , cannot find user by id, i-9 audit trail migration, employee user id, user id update, onboarding 1.0, onboarding 2.0. , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem

Product

SAP SuccessFactors Onboarding 2505