SAP Knowledge Base Article - Public

3681556 - Team View filter is not working in Executive Review - Compensation

Symptom

When attempting to filter the population on Team View in Executive Review, no employees are displayed. However, if we search for an individual user who belongs to the team we previously tried to filter, that user does appear.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Compensation

Reproducing the Issue

  1. Go to Executive Review
  2. Open a template
  3. Open population filter
  4. Select team view and add a planner
  5. Click on ok -> no users appear
  6. Then search on find user for a specific employee that is under that planner
  7. User appears

Cause

This behavior is caused due to break in the hierarchy.

Resolution

Download the UDF and identify the manager (or second manager, depending on the hierarchy used). Then, trace the reporting line for all managers. A cyclic hierarchy occurs when, for example, Manager A reports to Manager B, Manager B reports to Manager C, and Manager C reports back to Manager A.


When such a cycle exists, it breaks the reporting hierarchy, and as a result, the team view filter will not function properly. To resolve this issue, the hierarchy must be corrected to remove any cyclic reporting relationships. 

Keywords

executive, review, population, filter, team, view, user, employee, planner, not, working, find , KBA , LOD-SF-CMP-EXR , Executive Review , Problem

Product

SAP SuccessFactors Compensation all versions ; SAP SuccessFactors HCM Suite all versions