SAP Knowledge Base Article - Public

3681579 - Integration commerce cloud with CPQ authorization issue

Symptom

Integration issue between Commerce Cloud and SAP CPQ. The following error message is being received: 

  • Error message: `HTTP operation failed invoking https://xx.cpq.cloud.sap/api/v1/quotes with statusCode: 400`.
  • Adapter Response body: `{"error":{"code":"112000","message":"You cannot perform this action because you do not have the required permissions. A user working in parallel with you on this quote changed the quote status or your access permissions have been changed.","target":"/api/v1/quotes","details":[],"internalMessage":""}}`.

Environment

SAP CPQ

Reproducing the Issue

  1. Implement the connection between Commerce Cloud and CPQ using the integration package: SAP Commerce Integration with SAP CPQ for Quote 2.0.
  2. Initiate the flow `Replicate_Quote_from_SAP_Commerce_to_SAP_CPQ`.
  3. Send the quote from Commerce Cloud to SAP CPQ using the SSO user.
  4. Observe that the product and the involved party are not added, and the error message appears.

Cause

Using this iFlow (SAP Commerce Integration with SAP CPQ for Quote 2.0), clients can use OAuth 2.0 Client Credentials to authenticate data exchange between applications without requiring a specific user.

Resolution

CPQ supports OAuth 2.0 Client Credentials grant type.
Here is the OAuth 2.0 Client Credentials Authentication | SAP Help Portal with instructions on how it works. 

See Also

Refer to: Trusted Application Setup in SAP CPQ

Keywords

SAP CPQ, Commerce Cloud integration, authorization issue, OAuth 2.0, client credentials, replicate quote, error code 112000, HTTP operation failed, statusCode 400, permissions error, SSO user, trusted application, authentication, authorization. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions