SAP Knowledge Base Article - Public

3682154 - "The email address domain does not match the tenant owner domain" error in Datasphere

Symptom

The requirement is to configure the email notification with emails that belong to a different domain than the System Owner domain.

Below error is raised during the configuration:

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

  • SAP Datasphere 1.0

Cause

Email addresses must match the domain of the tenant owner, for example, jdoe@sap.com.

Resolution

This behavior is as per the current product design to ensure security compliance. Direct usage of a non-tenant domain is not supported, as it could lead to misuse of the feature and unintended involvement of SAP in external domain control.

As a workaround, you may create a user account within your Datasphere tenant using the required email domain and add that user as a tenant user. Once added, you can configure this tenant user in the email notification settings.

As a best practice, we recommend using Distribution Lists (DLs) instead of individual email addresses when configuring email notifications. This ensures continuity, as DLs are easier to manage and are not impacted when individuals leave the organization. Note that you must enable this setting in your email service.

See Also

Configure Email Notification for Replication Flow Failure at Object Level

Keywords

Notification, email, DWC, Datasphere, DL, list, recipient, address, domain , KBA , DS-DI-RF-UI , Replication Flow editor, monitoring and deployment , Problem

Product

SAP Datasphere 1.0

Attachments

Screenshot 2025-10-31 141455.png