Symptom
The 'Customer Usage Data' standard report fails when executed from the 'Saved Reports' tab under Learning Administration > Reports.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Log into the system.
- Navigate to Learning Administration & go to Reports.
- Search for 'Customer Usage Data'.
- Select a date in 'From Date'.
- Schedule the job.
- Confirm that the report succeeds.
- Go back to 'Reports'.
- Click on the 'Saved Reports' tab.
- Search for the saved 'Customer Usage Data' report.
- Click on 'Launch'.
- Select the same date in 'From Date'.
- Schedule the job.
- Confirm that the report fails.
Cause
Based on the investigation conducted by our Learning Engineering Team, the issue specifically occurs with saved Customer Usage Data reports where the 'To Date' field is not populated.
Resolution
The issue has already been fixed and will be implemented in the next major release, 1H2026, according to the schedule shared on the Product Release and Road Map Information page.
As a workaround, schedule the 'Customer Usage Data' report either immediately or as a recurring schedule, rather than saving it. This flow works correctly even if the 'To Date' field is not populated. Alternatively, customers can enter a value in the 'To Date' filter when submitting the job via the 'Saved Reports' tab.
Keywords
customer usage data, lms, report, report failure, saved reports, error generating report, standard, Error generating report CustomerUsageData, LRN-203527 , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , Known Error
SAP Knowledge Base Article - Public