SAP Knowledge Base Article - Public

3682529 - Note Type Field Missing In Condition Block for Case Custom Objects

Symptom

While creating a determination or validation within the Case service, you noticed that the {notes/noteType} field is missing into the conditions block.

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Navigate to the User Icon.
  2. Go to Settings > All Settings.
  3. Go to Extensibility Administration.
  4. Select Case Service > Case.
  5. Go to the Validations tab.
  6. Click on "+" (i.e., create).
  7. Select Forms.
  8. In Condition Block, try adding {notes/noteType}.
  9. You can not find it.

Cause

 The Note Type field (i.e., {notes/noteType} ) is a reference field of keyGroup Notes which is not added in the configuration file for Case and hence it is not available for usage in condition blocks.

Resolution

The "Note Type" field, represented as {notes/noteType}, is currently not supported within the conditions blocks for custom objects in the Case service.

The only viable workaround is to use External Hooks. By implementing this, you can receive the "Note Type" field (i.e., {notes/noteType}) through the payload that the Case service sends to the third-party system. Once received, you can then leverage this field as conditions within your external logic.

You may refer to the following document for reference: Create External Hooks

See Also

Keywords

note type, notes/noteType, noteType, conditions block, extensibility administration, case, validation, determination, missing, field , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM-CUL , Custom Logic for for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions