Symptom
The error “National ID is already in use” occurs in Employee Central when importing dependent records, if two employees have a dependent record for the same child (sharing the same National ID) and both records are included in the same CSV file.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
1. Login into the system.
2. Prepare a CSV file with two employees, each having a dependent record for the same child (same National ID).
3. Import both records together in a single CSV file.
4. Observe that the system throws an error "National ID is already in use".
Cause
This behavior has been identified as a defect.
The system currently allows dependent records with the same National ID only when each record has a unique personIdExternal and they are imported separately (in different CSV files).
Resolution
Workaround: Import the dependent records in separate CSV files.
Permanent Fix: Engineering has planned a resolution in the upcoming 2605 release.
Keywords
Dependent Import, National ID, Employee Central, CSV Import Error, ECT-262735 , KBA , LOD-SF-EC-DPD , Dependents Management , Problem
SAP Knowledge Base Article - Public