Symptom
- Sorting functionality for content objects does not work as expected when clicking "Object-ID".
- Document links under items do not guarantee sorting order, and there is no sorting function in the header.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to Learning Administration.
- Select Content.
- Choose Content Objects.
- Search and click "Object-ID", observe the sorting behavior.
- Navigate to Learning Administration.
- Select Learning Activities.
- Choose Items.
- Search for an item and go to Document Links.
- Add more links from the list and observe the sorting behaviour.
Cause
- Sorting order is determined by HANA database queries, which prioritize lower case, upper case, and numbers in ascending or descending order.
- Document links under items do not have a sorting function in the header, and the order is directly influenced by HANA database behavior.
Resolution
- Confirm that the LMS application reflects the sorting order returned by HANA database queries.
- Note that the sorting expectation is as follows:
- Lower case is treated with lower priority than upper case.
- Upper case is treated with lower priority than numbers.
- Ascending order example: 1, abc, ABC, 123.
- Descending order example: 123, ABC, abc,
- Document links under items do not guarantee sorting order due to the absence of a sorting function in the header.
- The sorting issue is confirmed to be caused by HANA database behavior, and no changes can be made from the application side.
- For further assistance, it is recommended to raise a ticket to the HANA team to address the sorting issue.
See Also
Refer to: 2331471 - How to provide Feedback on Case handling via SAP Support Interaction Survey - SAP for Me
Keywords
sorting functionality, content objects, document links, sap successfactors learning, object id, hana database, sorting order, lms application, ascending order, descending order, configuration issue, lms , KBA , LOD-SF-LMS-ITE , Items , Problem
Product
SAP SuccessFactors Learning all versions
SAP Knowledge Base Article - Public