SAP Knowledge Base Article - Public

3683332 - SEOD: BOUNCE EMAIL is NOT on UI even though E-mail sent by Workflow is to Invalid E-mail Address

Symptom

Bounce Email is not received on a Ticket Interaction UI for an e-mail sent to an invalid e-mail address by a workflow.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite

  • There is an E-mail Type Workflow Rule which sends an e-mail
  1. Go to the Service work center
  2. Go to the Tickets view
  3. Open the Ticket 123 (Where 123 refers to the Ticket ID)
  4. On this ticket, the workflow was triggered and sent an e-mail to an invalid e-mail address
  5. Go to the Interactions tab

Result: There is no Bounce Email

Expected Result: There is a Bounce E-mail as the e-mail was sent to an invalid e-mail address.

Cause

  • When an e-mail is sent to an invalid e-mail address from a ticket manually, there is a Bounce E-mail on UI. However, this does not happen for a scenario that e-mail is sent by a workflow rule.
  • This is due to a difference in their Message-IDs. Manual emails contain "SERVICE_ONDEMAND" while workflow emails contain "OM_Email".
  • This is the intended system behaviour.

Resolution

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available. 

An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:

Keywords

e-mail, email, bounce, workflow, invalid, incorrect, wrong, address, MIME , KBA , LOD-CRM-SC-EML , Email , Problem

Product

SAP Cloud for Customer core applications all versions