Symptom
Bounce Email is not received on a Ticket Interaction UI for an e-mail sent to an invalid e-mail address by a workflow.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite
- There is an E-mail Type Workflow Rule which sends an e-mail
- Go to the Service work center
- Go to the Tickets view
- Open the Ticket 123 (Where 123 refers to the Ticket ID)
- On this ticket, the workflow was triggered and sent an e-mail to an invalid e-mail address
- Go to the Interactions tab
Result: There is no Bounce Email
Expected Result: There is a Bounce E-mail as the e-mail was sent to an invalid e-mail address.
Cause
The message ID which is generated by the workflow is different to the outgoing message ID.
For example, the message ID which was generated by the workflow is (e.g <0ABC123DEF456SB987XYZ654@my31234.mail.crm.ondemand.com>), however the outgoing message ID is (e.g. <0ABC123DEF456SERVICE_ONDEMANDB987XYZ654@my31234.mail.crm.ondemand.com>)
Resolution
Maintain the original message ID to be presented in the message ID or In-Reply-To header.
Keywords
e-mail, bounce, workflow, invalid, incorrect, wrong, address, MIME , KBA , LOD-CRM-SC-EML , Email , Problem
SAP Knowledge Base Article - Public