SAP Knowledge Base Article - Public

3683603 - Custom token to fetch user's Preferred Name does not work in "Pre Onboarding Rehire Template" - Onboarding

Symptom

  • Custom token mapped to the email template fails to function in the email body, although it works in other templates.
  • Custom token won't populate information in "Pre Onboarding Rehire Template".
  • Custom tokens do not work for the specific email template "Pre Onboarding Rehire Template".

Environment

SAP SuccessFactors Onboarding.

Cause

The Preferred Name token won't be supported as user itself is not created and so we will not be able to fetch user details. Post first rehire verification only user will be identified. This is expected behavior.

Resolution

Standard tokens, such as [[FirstName]][[LastName]], should be used instead in the "Pre Onboarding Rehire Template" to ensure functionality.

Keywords

email, services, link, broken, custom, token, pre, onboarding, rehire, template, populating, showing, show, populate, sap, successfactors, onboarding, template, customization, mapping, body, notifications, preferred, name , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions