SAP Knowledge Base Article - Public

3684287 - Partner 12345 locked centrally or flagged for deletion in Maintain Business Partner App - S/4HANA Cloud Public Edition

Symptom

In the Maintain Business Partner App when the Import of Partner button is clicked for a certain company code, error message appears: "Partner 12345 locked centrally or flagged for deletion" (where 12345 stands for the partner number)(message no.: B0164)

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Maintain Business Partner App and select a BP
  2. Select Financial Services BP business role
  3. Click on the Company Code button
  4. Click on the Switch Between Display and Change button
  5. Enter Company code
  6. Click on the Import of Partner button
  7. Enter value in the CoCd field
  8. Enter value 12345 in the From Partner field (where 12345 stands for the partner number)
  9. Error message appears: "Partner 12345 locked centrally or flagged for deletion" (message no.: B0164)

Cause

System works as designed

Resolution

It is not possible to import data from a partner, which is locked centrally or flagged for deletion. Remove the flag from "Archiving Flag" and/or "Central Block" as below. The Archiving Flag is set, when a BP is flagged for deletion, the Central Block is set, when a BP is locked centrally.

  1. Open the Maintain Business Partner App and select a BP
  2. Select Financial Services BP business role
  3. Go to the Status tab
  4. Click on the Switch Between Display and Change button
  5. Remove flag "Archiving Flag" in the Archiving Flags and/or "Central Block" from the Locks section of the page

Keywords

business partner, BP, Maintain business partner, import, import of partner, company code, Archiving Flag, Central Block, flagged for deletion, B0164 , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions