Symptom
In the Maintain Business Partner App when the Import of Partner button is clicked for a certain company code, error message appears: "Partner 12345 locked centrally or flagged for deletion" (where 12345 stands for the partner number)(message no.: B0164)
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Maintain Business Partner App and select a BP
- Select Financial Services BP business role
- Click on the Company Code button
- Click on the Switch Between Display and Change button
- Enter Company code
- Click on the Import of Partner button
- Enter value in the CoCd field
- Enter value 12345 in the From Partner field (where 12345 stands for the partner number)
- Error message appears: "Partner 12345 locked centrally or flagged for deletion" (message no.: B0164)
Cause
System works as designed
Resolution
It is not possible to import data from a partner, which is locked centrally or flagged for deletion. Remove the flag from "Archiving Flag" and/or "Central Block" as below. The Archiving Flag is set, when a BP is flagged for deletion, the Central Block is set, when a BP is locked centrally.
- Open the Maintain Business Partner App and select a BP
- Select Financial Services BP business role
- Go to the Status tab
- Click on the Switch Between Display and Change button
- Remove flag "Archiving Flag" in the Archiving Flags and/or "Central Block" from the Locks section of the page
Keywords
business partner, BP, Maintain business partner, import, import of partner, company code, Archiving Flag, Central Block, flagged for deletion, B0164 , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem
SAP Knowledge Base Article - Public