Symptom
Users are facing issues while syncing absence and holiday to calendar in Teams.
Even with the required permissions, users still unable to load data for absences and holidays in Teams despite having the option available.
Teams displays the error message: "Unable to load the data".
Environment
SAP SuccessFactors Employee Central 2H 2025
SAP SuccessFactors Employee Central Time Off 2H 2025
Reproducing the Issue
1) Verify that the user has all permissions in SAP SuccessFactors to create absence, view time type/time account, and view holiday calendar.
2) Attempt to sync absence and holiday data to calendar in Teams for the affected user.
3) Observe the following:
- User sees the absence and holiday option in Teams but is unable to load data.
- User does not see the absence and holiday option in Teams.
4) Teams displays the error message: "Unable to load the data".
Cause
This is a Known Issue.
Resolution
Product Engineering is investigating a solution.
Click on star to bookmark this article to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs.
Workaround
In the meantime, we have prepared a workaround to address the issue. Please follow these steps:
1. Navigate to the SF system.
2. Go to **Manage Home Page** -> **Manage Quick Actions and Quick Links**.
3. Adjust the order of the options by changing the position of "Request Time Off." You can either move it down, for example, after "Give Feedback," or move it to the front, before "Manage My Team."
Implementing this workaround should resolve the problem temporarily until the fix date.
See Also
- SAP SuccessFactors Product Release & Road Map Information
- SAP SuccessFactors Patches Knowledge Base
- KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs
Keywords
SAP Knowledge Base Article - Public