SAP Knowledge Base Article - Public

3684400 - Error When Re-Initiating Manual Onboarding and Inconsistent Start Date in Data Inspector

Symptom

  • An error occurs when attempting to re-initiate onboarding for a candidate whose previous onboarding process was canceled as "No Show." The system displays the error message: "You can't initiate manual onboarding for users whose manual onboarding processes were canceled previously. Please purge the user information and try again."
  • Despite the error message, the system updates the canceled record, changing the start date while leaving the end date unchanged, resulting to inconsistent data in Data inspector

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Initiate onboarding using "Add New Hire to Onboarding" with a start date (e.g., 21 Jul 2025).
  2. Cancel the onboarding process as "No Show," resulting in the end date being set to 21 Jul 2025.
  3. Attempt to re-initiate onboarding using the same email and a new start date (e.g., 28 Jul 2025).
  4. Observe the error message: "You can't initiate manual onboarding for users whose manual onboarding processes were canceled previously. Please purge the user information and try again."
  5. Check the backend data (data inspector Tables) and note that the start date of the canceled record is updated to 28 Jul 2025, while the end date remains 21 Jul 2025.

Cause

  • The issue occurs due to the application updating details in respective tables after user confirmation for the prompt: "This user already exists in the system. Do you want to initiate onboarding for the existing user?" However, the update results in inconsistent data, with the start date being updated while the end date remains unchanged.

Resolution

  1. Once an onboarding process is cancelled, the user is marked as inactive in the Users_SysInfo entity.
  2. For downstream integrations, ensure that only users with a valid/active status are considered. This will ensure that downstream systems receive only active user records.

Note:

  • Engineering has confirmed that a code correction is required to address this behavior. However, the fix is complex as it impacts multiple related flows. The correction is planned for an upcoming release.
  • The solution of this issue is currently under investigation. Please follow this KBA for updates.

See Also

Keywords

onboarding error, manual onboarding issue, canceled onboarding process, start date update, end date unchanged, inconsistent data, sap successfactors onboarding, re-initiate onboarding, no show error, user record overwrite, onboarding process canceled , KBA , LOD-SF-OBX-MAN , Manual Onboarding , Problem

Product

SAP SuccessFactors Onboarding 2505