Symptom
- Create New S/4HANA or BW Live Connection in SAC(Connection type: Direct/Tunnel), the following error pop-up:
Error: We couldn't connect to your S/4 HANA or BW system. Possible causes: You are using the wrong credentials or CORS is not configured correctly. For more information, see our troubleshooting page.
Toubleshoot
Correction ID: XXXXXXXXXXXX - In HAR trace file, you may find the following error :
{
"Messages": [
{
"Type": 2,
"MessageClass": "/IWFND/CM_COS",
"Number": 2,
"Text": "System alias <alias> does not exist",
"ExceptionClass": "CX_BICS_INA_RFC_ERROR",
"OlapMessageClass": 0
},
{
"Type": 2,
"MessageClass": "SY",
"Number": 530,
"Text": "An exception was raised.",
"ExceptionClass": "/IWFND/CX_COF",
"OlapMessageClass": 0
},
{
"Type": 2,
"MessageClass": "/IWFND/CM_COS",
"Number": 2,
"Text": "System alias <alias> does not exist. Diagnosis An SAP system alias was deleted after it had been used to process Generic Service Data Objects (GSDOs). These GSDOs have been sent to a consumer together with their SAP system alias information. But this alias no longer exists. SAP Gateway cannot connect to the corresponding SAP business system because of the missing system alias. System Response Requests from a consumer for these GSDOs cannot be processed by SAP Gateway. Procedure Carry out one of the following options: Create the SAP system alias again and make sure it points to the same SAP business system as before. Delete the corresponding GSDOs from the consumer database. Procedure for System Administration",
"ExceptionClass": "/IWFND/CX_DESTIN_FINDER",
"OlapMessageClass": 0
}
]
} - Open the url https://xxxx.analytics.cloud.sap/lcs/scc/tunnel/xxxx/sap/bw/ina/GetServerInfo/sap/bw/ina/GetServerInfo?sap-client=<ClientID> or
https://<s4hana or BW server: port>/sap/bw/ina/GetServerInfo/sap/bw/ina/GetServerInfo?sap-client=<ClientID>
in the browser, the same errors display.
Environment
SAP Analytics Cloud
Reproducing the Issue
- Open SAP Analytics Cloud (SAC).
- Create a S/4 HANA or BW live connection.
- Input S/4HANA or BW system info e.g.Host, port.etc.
- Click 'Save'.
Cause
The error "System alias <alias> does not exist" indicates that the alias configuration is wrong on the backend side.
Resolution
As per SAP Note 3255474 there are two routing mechanisms A, B.
- A Old routing from frontend server to backend server
- B New routing from frontend server to backend server using SAP Gateway service SAP_BW_INA_SRV
It is recommended to move customizing from the old mechanism to the new mechanism.
Note the old routing mechanism is still used as described in A when there exists a record in table RSADMIN with key OBJECT = RSBICS_INA_RFC_DEFAULT_ALIAS, the VALUE may even be empty. If the record in table RSADMIN with key OBJECT = RSBICS_INA_RFC_DEFAULT_ALIAS does not exist, routing will be processed based on B.
Select the routing mechanism based on the business requirements. In case it is decided to use routing mechanisms A, maintain the correct system alias for RSBICS_INA_RFC_DEFAULT_ALIAS .
To maintain the RSADMIN parameter RSBICS_INA_RFC_DEFAULT_ALIAS, use the report SAP_RSADMIN_MAINTAIN in transaction code SE38.
See Also
Keywords
SAC, live connection, S/4 HANA, system alias, FIORIS4H, RSBICS_INA_RFC_DEFAULT_ALIAS, RSADMIN, tunnel connection, SSO, error message, troubleshooting , KBA , LOD-ANA-LDC-BW , SAC Live Data Connection BW , BW-BEX-OT-BICS-INA , BW INA provider , Problem
SAP Knowledge Base Article - Public