SAP Knowledge Base Article - Public

3684598 - Unable to Assign Access Sequence to Header Condition Type in Pricing Configuration – SAP S/4HANA Cloud Public Edition

Symptom

An error encountered — "No access sequence to header condition", when assigning an access sequence to a Header Condition Type in configuration activity ' 101120- Set Condition Types for Pricing in Sales' , even though the condition table contains only header-level fields.

Environment

 SAP S/4HANA Cloud Public Edition 

Reproducing the Issue

  1. Configure a Condition Table using a header-level field (e.g., Sales Office) in configuration activity -'103120-Change Condition Tables for Pricing in Sales'.
  2. Assign this Condition Table to an Access Sequence in configuration activity-'103121 - Set Access Sequences'.
  3. Assign the Access Sequence to the Custom Condition Type in configuration activity-'101120- Set Condition Types for Pricing in Sales' , the system immediately prompts the error.

Cause

The error occurs because the Header condition (KKOPF) and Item condition (KPOSI) indicators in configuration activity-'101120- Set Condition Types for Pricing in Sales' are not marked, as these fields selected in the Condition Table and Access Sequence—header-level fields (e.g., customer) or a combination of header and item-level fields (e.g., division),hence selecting both header condition and item condition prevents the system from issuing the error message.

Resolution

Follow below steps for maintaining customer account group in Manage Your Solution' app:

  1. Open 'Manage Your Solution' app.
  2. Navigate to 'Configure Your Solution'.
  3. Search for the ID '500110'.
  4. Choose configuration activity '101120- Set Condition Types for Pricing in Sales'.
  5. Check mark the ‘Header condition’ (KKOPF) and ‘Item condition’ (KPOSI) indicators as these indicators control whether a condition can be manually entered at header or item level.

In case while using SAP Central Business Configuration (CBC) :

  1. Log on to the project experience in SAP Central Business Configuration.
  2. Select the relevant workspace.
  3. Navigate to the configurations activity tab. 
  4. Search for the configuration activity '101120- Set Condition Types for Pricing in Sales'.
  5. Select the configuration activity to navigate directly to the SAP S/4HANA Cloud system. 

Note: The actual classification of a condition as a header or item condition is determined by the key fields selected in the Condition Table and Access Sequence-header-level fields (e.g., customer) or a combination of header and item-level fields (e.g., division), hence selecting both header condition and item condition prevents the system from issuing the error message.

See Also

Keywords

header condition, access sequence, pricing configuration, sap s/4hana cloud public edition, kkopf, kposi, condition table, error message, no access sequence, header fields, pricing procedure. , KBA , SD-BF-PR-2CL , Pricing (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions