Symptom
Workflow Details Page does not display the field value changes that triggered the Workflow
Environment
SAP SuccessFactors Employee Central - Workflows
Reproducing the Issue
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Navigate to any employee profile.
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Open an effective-dated entity/portlet.
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Modify a field value and save the change.
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A workflow is triggered.
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Proxy as the approver and open the workflow for approval.
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Observe that the workflow does not display the details of the changed field value.
Cause
When more than one workflows are initiated for the same change, approval of one workflow causes the other workflows to stop showing the initial field value changes, as the data has already been updated and no more valid to compare the current value and new value.
Resolution
- As confirmed by Engineering, this is expected system behavior.
- Supported EC entities allow multiple workflows to be triggered in parallel to support concurrent HR processes. Hence you cannot hard stop from creating multiple workflows for the same change.
- Please approve the workflow or decline/cancel to remove it from pending approval.
Recommendation:
Users can be granted an appropriate permission to view Transactions Pending Approval. Once granted, the pending approval link will appear, indicating that a change has been requested and is awaiting approval.
If you believe this requirement should be enhanced in future releases, we recommend submitting an enhancement request as outlined in KBA 2090228.
See Also
SAP Note 2806015 - Workflow only shows those fields where data is changed - Employee Central
SAP Note 3190710 - Workflow Details page is empty, fields changed are not shown - Employee Central
Keywords
preferred name, workflow details page, SAP SuccessFactors Employee Central, duplicate workflows, HR approval, personal information changes, pending workflow, workflow validation, data changes, testing behavior, effective date changes,changes, change, field, value, current, new, old, not , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , How To
SAP Knowledge Base Article - Public