SAP Knowledge Base Article - Public

3685285 - Duplicate Country Code added to Employee phone number via API

Symptom

When an Employee's phone number is sent via API in the format "49 123 4567", the system automatically adds the country code "+49," resulting in duplication (e.g., "+49 49 123 4567").

This behavior occurs even though the country is already maintained in the Employee record.

Environment

SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Maintain an employee record in V2 with Country = Germany (DE).
  2. Send the phone number via API in the format "49 123 4567."
  3. Observe that the system transforms the number to "+49 49 123 4567".

Cause

The system will automatically add the country code to the phone number if it believes that there is no country code maintained

Resolution

Ensure that the phone number is maintained in the external system or API call with a "+" so that the system is aware there is already a country code.  For example, sending "+49 123 4567" will not result in the country code being duplicated

See Also

SAP Cloud for Customer: Always Prefix Your Phone Numbers with a Country Code

Keywords

duplicate country code, phone number duplication, employee record, sap service cloud version 2, C4C V2, API phone number format, country code duplication, +49, Germany phone number, employee API, phone number formatting, integration issue, communication channel issue, phone number parsing, S/4 data correction , KBA , CEC-CRM-EMP , Employee for SAP Sales/Service Cloud , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 all versions