SAP Knowledge Base Article - Public

3685400 - Error: Email #EMAIL ID in conflict with Employee #WORKER ID/ User ID #CB USER

Symptom

While creating or updating a worker in SAP S/4HANA Cloud Public Edition via SOAP API, MDI or JB1, following error is encountered:

"Unable to process workforce person record.

Email #EMAIL ID of Employee #WORKER ID is not unique.

Email #EMAIL ID in conflict with Employee #WORKER ID/ User ID #CB USER."

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Select the worker to update in External HR System.
  2. Send the update via chosen integration channel.
  3. Error will be reflected in Message Monitoring app in SAP S/4HANA Cloud Public Edition.

Cause

Email ID used during replication is not unique.

Resolution

Email ID of every worker should be unique. Hence during updating an existing worker or while creating a new one, assign a unique Email ID.

Keywords

SAP_1C, SAP_2C, Manage workforce, worker integration, soap api, jb1, mdi, ca-wfd-int , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem

Product

SAP S/4HANA Cloud Public Edition all versions