Symptom
- The diamond button for Joule is not appearing for a specific user despite the correct role-based permissions being assigned.
- Other users within the same permission group can access the button without issue.
- Joule icon not showing for a user.
Environment
Joule in SuccessFactors
Reproducing the Issue
- Login as an affected user
- Observe that the Joule button is not visible.
- Login as another user
- Observe that the Joule button is visible.
Cause
The issue is most likely caused by security policies of the network provider, which may be blocking certain URLs required for the button to appear.
User affected does not have the permission General User Permission > Access to Joule
Resolution
- Verify that the user is using the latest version of their browser and ensure third-party cookies are not blocked.
- Confirm that roles are properly synced to the affected user by following the steps outlined in SAP Knowledge Base Article 3619387.
- Ensure that the following URLs are allowlisted in the network firewall configurations:
- Allowlist SF
- IAS
- Joule
- Confirm user has the permission General User Permission > Access to Joule
In case permission is not available in your system, please review the implementation guides below to ensure Joule is properly integrated to your system:
- SAP Discovery Center Mission - Establish a Unified Joule Instance
- SAP Discovery Center Mission - Activate Joule for SAP SuccessFactors
Note: If the issue persists, please submit a ticket to LOD-SF-PLT-JOU
See Also
Keywords
successfactors, button not appearing, role-based permission, network security policies, allowlist URLs, firewall configuration, browser settings, third-party cookies, role synchronization, successfactors navigation, Joule, LOD-SF-PLT-JOU , KBA , LOD-SF-PLT-JOU , Joule in SuccessFactors , Problem
SAP Knowledge Base Article - Public