SAP Knowledge Base Article - Public

3686285 - An error "grouping BPEE has not been assigned to a customer account group" occurs when attempting to add the customer role to an employe

Symptom

There is an error "grouping BPEE has not been assigned to a customer account group" during the creation of the BP.

Environment

S/4HANA Cloud Public Edition 

Reproducing the Issue

  1. Access the Fiori Manage Business Partner Master Data.
  2. Select an employee.
  3. Edit the employee record.
  4. Create the FLCU00 customer role.

Cause

Although the flag "Allow creation of customer role with employee" is active, the system requires that the Business Partner (BP) grouping used by the employee must be assigned to a Customer Account Group. The BP grouping is not mapped to any Customer Account Group in the system, which prevents the creation of the customer role.

Resolution

  1. Go to SSCUI 102741 – "Define Number Assignment for Direction BP → Customer".
  2. Add an entry mapping the BP grouping to a valid Customer Account Group (e.g., 0001 / DEBI / or a custom Z* group).
  3. Save the configuration.
  4. Repeat the customer role creation process.
  5. Once the assignment is maintained, the system will allow the creation of the Customer Role (FLCU00) for the employee.
  6. If mapping all employees is not preferred, define a dedicated BP Grouping (e.g., ZEMP_CUST) and use it only for employees requiring customer functionality.

See Also

Refer to: 3356897 - How to generate Customer role for an employment BP in employee synchronization new function

Keywords

error adding customer role, customer account group not assigned, FLCU00 creation error, business partner grouping, sap s/4hana cloud public edition, employee BP error, customer role creation, SSCUI 102741, define number assignment, BP to customer mapping, ZEMP_CUST grouping , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions